Notification for the customers of UBB online banking

Dear clients,

We would like to inform you that in our strive to continuously maintain the high level of security of the products and services that we offer, as of 01.05.2019 the browsers, which support only the earlier version of the secure communication protocol TLS 1.0 will not be usable for access to the UBB electronic banking - UOnline.

If your browser or the operating system that you use do not support TLS, version 1.1 (or a newer one), you need to update them, in order to continue having access to the Internet banking service.

 

Sincerely, 

UBB team